来自Wiki
跳转至: 导航搜索
Main PageBuilder pane

可以在“ 视图”选项卡下或单击Toolbar RigidBody .png 主工具栏上的图标访问“构建器”窗格。

概述


" 构建器 " 窗格用于在Motive中创建和编辑可跟踪模型(也称为可跟踪资产)。通常,创建刚体模型以跟踪刚性对象,并且创建骨架模型以跟踪人类运动。

创建时,可跟踪模型将标记的位置存储在目标对象上,并使用该信息在3D空间中自动标记重建的标记。在自动标签处理期间,使用标记算法将一组预定义标签分配给3D点,然后使用标记数据集来计算相应刚体或骨架段的位置和方向。

可跟踪模型可用于在实时模式(实时)和编辑模式(后处理)中自动标记3D捕获。每个创建的可跟踪模型都有自己的属性,可以在"属性"窗格下查看和更改这些属性。如果在后处理过程中创建了新的骨架或刚体,则需要再次自动标记Take以将更改应用于3D数据。

  • Motive中的刚体,带有自动标记的标记
  • Motive中的骨架,带有自动标记的标记

界面概述

在'" 构建器 "窗格中,您可以创建新的可跟踪资产或修改现有资产。在窗格底部选择刚体或骨架,然后选择是否要创建或编辑。每个功能将在下面的部分中解释。


TrackablesPane Overview.png

刚体:创建


要创建刚体,请选择底部的刚体选项,然后访问顶部的“ 创建”选项卡。在这里,您可以创建刚体资产并跟踪卷中的任何市场对象。除了标准的刚体资产外,您还可以为头戴式显示器(HDMs)和测量探头创建刚体模型。

创建刚体

第1步.

3D视口中选择所有关联的刚体标记。

第2步.

在"构建器"窗格上,确认所选标记与要从中定义刚体的标记匹配。

第3步.

单击" 创建"以从所选标记定义刚体资产。

Info2.png

其他创造刚体的方法

您还可以在选择标记时执行以下操作来创建刚体:

  • 预览视图(3D视口): 选择标记后,右键单击透视视图以访问上下文菜单。在"刚体"部分下,单击" 从选定标记创建"。
  • 资产窗格: 在Motive中选择标记时,单击IconAdd.png "资源"窗格中的“添加” 按钮。
  • 热键:选择标记后,使用创建刚体热键(默认值:Ctrl + T)。
Asset RBRightClick.png Asset RBbat.png

第4步.

创建刚体资产后,标记将被着色(标记)并相互连接。新创建的刚体将列在" 资源"窗格下

Info2.png

如果在编辑模式下创建了刚体或骨架,则需要自动标记相应的Take。只有这样,刚体标记将使用刚体资产进行标记,并且将为每个帧计算位置和方向。

创造一个僵硬的身体

创建HMD刚体

在"生成器"窗格中创建HMD刚体。

此功能仅可用于安装了OptiTrack Active HMD夹子的HMD

为了将OptiTrack系统用于VR应用,重要的是将HMD刚体的枢轴点放置在适当的位置,该位置位于眼睛之间的鼻根处。使用HMD剪辑时,您可以使用“构建器”窗格中的HMD创建工具让Motive估计此点并相应地放置轴心点。它利用夹子上的已知标记配置来精确定位枢轴点并设置所需的方向。

Info2.png

具有被动标记的HMD可以利用外部枢轴对准工具来校准枢轴点。

步骤

  1. 首先,确保Motive配置为跟踪活动标记
  2. " 视图"选项卡下打开" 构建器"窗格,然后单击" 刚体"。
  3. 在" 类型"下拉菜单下,选择"HMD"。这将提出定义HMD刚体的选项。
  4. 在" 方向"下拉菜单下,选择所需的HMD方向。用于流式传输到Unity的方向是+ Z 方向,而虚幻引擎是+ X 方向,或者您也可以在客户端插件端指定预期的方向轴。
  5. 将HMD保持在跟踪体积的中心,可以很好地跟踪所有活动标记。
  6. 3D视口中选择8个活动标记。
  7. 点击创建。将从所选标记创建HMD刚体,并将启动校准过程。
  8. 在校准期间,缓慢旋转HMD以收集不同方向的数据样本。
  9. 一旦收集了所有必要的样品,将创建校准的HMD刚体。

创建测量探针刚体

在Motive中校准探针

为了将OptiTrack系统用于VR应用,重要的是将HMD刚体的枢轴点放置在适当的位置,该位置位于眼睛之间的鼻根处。使用HMD剪辑时,您可以使用“构建器”窗格中的HMD创建工具让Motive估计此点并相应地放置轴心点。它利用夹子上的已知标记配置精确地将枢轴点设置为所需的方向。

有关更多信息:测量探针套件指南

步骤:探针校准

  1. 在" 视图"选项卡下打开“ 构建器”窗格,然后单击“ 刚体”。
  2. 将探头带入跟踪体积,并从标记中创建刚体
  3. 在" 类型"下拉菜单下,选择" 探测"。这将为测量探针定义刚体提供选项。
  4. 选择在步骤2中创建的刚体。
  5. 将探头尖端放置并装配在提供的校准块上的一个插槽中。
  6. 请注意,校准过程中将有两个步骤:精炼刚体定义和校准枢轴点。单击" 创建"按钮以启动探针优化过程。
  7. 将探头缓慢移动成圆形图案,同时保持尖端安装在插槽中; 整体形成锥形。轻轻旋转探头以收集其他样品。
  8. 完善后,它将自动进入下一步; 枢轴点校准。
  9. 重复相同的运动以收集额外的样品数据,以精确计算枢轴或探针尖端的位置。
  10. 收集到足够的样本后,枢轴点将位于探头尖端,并显示平均尖端错误。如果探头校准不成功,只需从步骤4再次重复校准。
  11. 成功校准探头后,探头资产将显示在Motive中的刚体上,实时x / y / z位置数据将显示在" 测量"窗格的"实时测量"部分下。

步骤:样品采集

  1. 在" 工具"选项卡下,打开" 测量"窗格
  2. 将探头尖端放在您想要收集的点上。
  3. 单击"测量"窗格上的" 采样 "。
  4. 将在该点处创建虚拟重建,并且将在测量窗格上显示相应的信息。采样点也将保存在导出到项目目录中。
  5. 收集额外的样本将提供收集的样本之间的距离和角度。
使用测量探头采样3D点。

刚体:编辑


使用" 构建器"窗格,您还可以修改现有的刚体资产。要编辑刚体,请选择"构建器"窗格底部的刚体选项,然后访问顶部的" 编辑"选项卡。这将显示编辑刚体的选项。

优化

使用RigidBody Refinement工具改进资产定义。

仅在实时模式下支持此功能。

刚体细化工具提高了Motive中刚体计算的精度。最初创建刚体资产时,Motive仅引用单个框架来定义刚体定义。刚体细化工具允许Motive在实时模式下收集其他样本,以获得更准确的跟踪结果。更具体地,该特征改进了刚体的预期标记位置的计算以及刚体本身的位置和取向。

步骤

  1. View选项卡下,打开Builder窗格
  2. 选择窗格底部的“ 刚体选项”选项,然后转到“编辑”选项卡。
  3. 实时模式下,选择要优化的现有刚体资产。
  4. 将选定的刚体保持在捕获体的中心,以便尽可能多的摄像机可以清晰地捕获刚体上的标记。
  5. 按下启动优化构建器窗格
  6. 慢慢旋转刚体以收集不同方向的样品。
  7. 收集完所有必要的样品后,将显示细化结果。

探头校准

探头校准下刚体编辑选项功能可用于重新校准测量探针或定制刚体的枢转点。在首次创建测量探针时,此步骤也作为校准步骤之一完成,但您可以在“ 编辑”选项卡下重新校准该步骤。

步骤

  1. 在Motive中,选择刚体或测量探头。
  2. 将探头带入跟踪体积,其中所有标记都被良好跟踪。
  3. 将探头尖端放置并装配在提供的校准块上的一个插槽中。
  4. 单击开始
  5. 一旦开始收集样品,将探针缓慢移动到圆形图案中,同时保持尖端安装在槽中; 整体形成锥形。轻# 轻旋转探头以收集其他样品。
  6. 收集到足够的样本后,将显示校准枢轴点的平均误差。
  7. 单击“ 应用”以使用校准定义,或单击“ 取消”再次进行校准。

位置/方向

用于平移和旋转刚体枢轴点的选项。

编辑”选项卡用于将平移或旋转应用于选定刚体的轴心点。刚体的枢轴点表示相应资产的位置(x,y,z)和方向(俯仰,滚转,偏航)。

Info2.png

您还可以使用Gizmo工具快速修改刚体的轴心点

位置

使用此工具可以转换x / y / z轴(以mm为单位)的轴心点。您还可以重置平移以将枢轴点设置回刚体的几何中心。

方向

使用此工具将旋转应用于所选刚体的局部坐标系。您还可以重置方向以对齐刚体坐标轴和全局轴。
重置方向时,必须在场景中跟踪刚体。

OptiTrack剪辑工具

OptiTrack Clip Tool基本上使用OptiTrack HMD Clips重新校准HMDs,将其枢轴点定位在适当的位置。这些步骤与首次制作HMD刚体时的步骤基本相同。

外部枢轴对齐

为了将OptiTrack系统用于VR应用,重要的是将HMD刚体的枢轴点放置在适当的位置,该位置位于眼睛之间的鼻根处。外部枢轴对齐工具利用OptiTrack mocap系统和HMD自己的跟踪系统(Oculus Tracker / Vive基站)来精确计算HMD枢轴点的位置。使用此功能时,两个系统必须同时跟踪HMD。

Info2.png

HMD兼容性说明:

  • 对于Motive版本2.1 Final和更高版本: 支持Oculus和Vive HMD。
  • 对于早期版本的Motive:仅支持Oculus HMD。
  • 相应的原生HMD跟踪器必须同时跟踪HMD以及运动捕捉系统。
  • 对于CV1主动HMD剪辑,将单独提供刚体定义。

步骤

  1. 首先,连接HMD Tracker(Oculus Tracker / Vive基站)并在后台运行相应的软件。
  2. 启动Motive。
  3. [Motive]从HMD上的标记创建刚体资产。
  4. [Motive]打开Builder窗格并访问刚体的编辑选项。
  5. [Motive]在Motive中选择HMD刚体。
  6. [Motive→Builder pane]在Detected Type下,它应指示Custom RigidBody
  7. [Motive→Builder pane]设置所需的样品计数(默认值:750)和所需的方向。
  8. [Motive→Builder pane]按开始启动采样过程。
  9. [Motive→Builder pane]在校准期间,确保mocap系统和HMD跟踪器(Oculus Tracker / Vive基站)正在跟踪HMD。
  10. [Motive→Builder pane]一旦开始收集样本,将HMD指向跟踪器并缓慢旋转它并采样不同的方向。
  11. [Motive→Builder pane]当完成采集样本时,它将显示由HMD跟踪系统和动作捕捉系统检测到的枢轴点位置之间的偏移距离(mm)。
  12. [Motive→Builder pane]如果结果令人满意,请按应用以校准HMD刚体。

球面枢轴放置

跟踪球形物体(例如球)时,此功能非常有用。假设所选刚体上的所有标记都放置在球形物体的表面上,并且将计算枢轴点并相应地重新定位。只需在Motive中选择刚体,打开“ 生成器”窗格以编辑刚体定义,然后单击“ 应用”将轴心点放置在球形对象的中心。

骨架:创建

要在Motive中创建骨架,需要在“ 生成器”窗格底部选择骨架选项,然后访问顶部的“ 创建”选项卡。在这里,您可以选择要使用的骨架标记物,选择校准柱,然后创建骨架模型。

创建骨架

从骨架标记物中定义骨架。

第1步。

从“ 构建器”窗格中的骨架创建选项中,从“ 标记集”下拉菜单中选择骨架标记集。这将显示骨架化身,显示标记需要放置在主体上的位置。

第2步。

请参阅头像并相应地将标记放在主题上。要获得准确的放置位置,请在放置标记时让拍摄对象站在校准姿势。重要的是将这些标记放置在受试者身体的正确位置以进行最佳骨架追踪。因此,放置骨架标记时需要特别注意。

Info2.png

品红色标记表示可以放置在同一段内稍微不同位置的段标记

第3步。

仔细检查标记计数及其位置。在Motive中使用3D视口可能更容易。系统应该在此时跟踪附加的标记。

第4步。

在“构建器”窗格中,确保“ 需要的标记”和“ 检测到的标记”部分下的数字匹配。如果未自动检测到骨架标记,请从3D透视视图中手动选择骨架标记。

第5步。

在“ 标签”部分下选择一组所需的标记标签。在这里,您可以使用默认标签来指定由markerset模板定义的标签。或者,您还可以通过在标签部分中加载以前准备好的标记名称XML文件来分配自定义标签。

第6步。

下一步是选择骨架创建姿势设置。在“ 姿势”部分下拉菜单下,选择要用于定义骨架的所需校准柱。默认设置为T-pose。

第7步。

让拍摄对象站在选定的校准姿势中。在这里,站在适当的校准姿势很重要,因为创建的骨架的姿势将从中校准。有关更多详细信息,请阅读校准姿势部分。

第8步。

单击“创建”以创建骨架。定义骨架模型后,确认所有骨架段和指定的标记位于预期位置。如果任何骨架段似乎未对齐,请在调整标记放置位置和校准姿势后再次删除并创建骨架。

Info2.png

在编辑模式下

如果要在捕获数据的后处理中创建骨架,则必须自动标记 Take以查看在Motive中建模和跟踪的骨架。

Info2.png

虚拟现实市场

VR应用程序的骨架标记具有略微不同的设置步骤。请参阅:刚体骨架Markerset

骨架:编辑


要在Motive中创建骨架,您需要选择“构建器”窗格底部的骨架选项,然后访问顶部的“ 编辑”选项卡。

从标记重新校准

可以使用现有骨架信息重新校准现有骨架资产。基本上,重新校准使用相同的骨架标记集重新创建所选骨架。此功能重新校准骨架资产并刷新资产上的预期标记位置。

要重新校准骨架,请从透视图中选择所有关联的骨架标记以及相应的骨架模型。打开“ 构建器”窗格,然后在底部选择“骨架”选项时打开“编辑”选项卡。确保选定的骨架处于校准姿势,然后单击“ 重新校准”。您还可以从“ 资源”窗格或“ 3D视口”中的上下文菜单中重新校准。

Info2.png

骨架重新校准不适用于添加了标记的骨架模板。

  • 从“资源”窗格中的选定标记重新校准。
  • 从“资源”窗格中的选定标记重新校准。
  • 从“透视视图”窗格中的选定标记重新校准。