来自Wiki
跳转至: 导航搜索

范围

图形视图”窗格用于可视化Motive中的跟踪数据。可以从命令栏(“ 视图”选项卡>“图形”)或单击文件:GraphViewIcon 20.png图标轻松访问此窗格。此页面提供有关如何有效利用Motive中的“图形视图”窗格的说明和提示。


目录

概述


使用“ 图形视图”窗格,您可以可视化和监视多个数据通道,包括重建标记的3D位置,可跟踪资源的6自由度(6 DoF)数据以及来自集成外部设备(例如测力台或NI-DAQ)的信号。“图形视图”窗格提供了各种图形布局,以实现最有效的数据可视化。除了基本布局(通道、组合、间隙)之外,还可以创建自定义布局以仅监视特定数据通道。每个布局最多可以绘制9个图形,并且可以在Motive中同时打开最多两个窗格。

可以在实时和编辑模式下绘制图形。

  • 在实时模式下,可以实时绘制以下数据:
- 刚体6 DoF数据(位置和方向)
- 测力台数据(力和力矩)
- 模拟数据
  • 在编辑模式下,图表可用于查看和后处理捕获的数据:
- 重建标记的3D位置
- 刚体6 DoF数据(位置和方向)
- 测力台数据(力和力矩)
- 模拟数据
Graph View pane in Motive.

工具栏

Graph view toolbar.
图标 名称 描述
Graph Editor 20.png
图形编辑器 这将打开侧边栏,用于自定义布局中的选定图形。
Graph Autoscale 20.png
自动缩放图 切换到自动缩放X / Y / Z图
Timeline Recenter.png
缩放适合

(选定范围)

缩放到选定的帧区域并相应地使时间线居中
Graph LockCenter 20.png
锁定光标居中 将时间线滑块锁定在视图范围的中心。
Graph Delete 20.png
删除所选键 删除选定的框架区域。
View3D TranslateMode.png
移动选定的键 转换所选框架区域中的轨迹。选择一个范围并在轨迹上上下拖动。
Timeline DrawKeys.png
绘画键 通过在编辑器中单击并拖动选定的轨迹来手动绘制轨迹。
Graph MergeUp 20.png
合并键 将两个轨迹合并在一起。与“ 轨迹视图”图形一起使用时,此功能非常有用。选择两个轨迹并单击此按钮将顶部轨迹合并到底部轨迹中。
Graph MergeDown 20.png
合并键向下 将两个轨迹合并在一起。与“ 轨迹视图”图形一起使用时,此功能非常有用。选择两个轨迹并单击此按钮将底部轨迹合并到顶部轨迹中。
Graph SelectionLock 20.png
锁定选择 将当前选择(标记、刚体、骨架、测力台或NI-DAQ)锁定到布局上的所有图形上。它们用于暂时保留选择。稍后可以通过拍摄布局的快照来修复锁定的选择。这将在后面的部分详细阐述。

窗格菜单选项

图表视图窗格菜单

创建布局

创建新的图形布局。

删除布局

删除当前图形布局。

更新布局

将更改保存到图形布局XML文件中。

详细布局

获取当前图形布局的XML快照。一旦布局得到细化,布局配置和项目选择都将被修复,并且可以导出并导入到不同的会话中。

编辑布局

打开当前图形布局的布局XML文件以进行编辑。

显示布局

打开存储图形布局的XML文件的位置的文件位置。

图形导航


基本导航

在图上

导航帧(Alt +左​​键单击+拖动)

按住Alt +左​​键单击图形并左右拖动鼠标以浏览记录的帧。您也可以使用鼠标滚动执行相同操作。

平移(滚动点击+拖动)

滚动单击并拖动以在整个绘制的图形中垂直和水平平移视图。向左和向右拖动光标将沿着水平轴平移视图以用于所有图形。垂直导航时,滚动单击图形并向上和向下拖动以垂直平移特定图形。

缩放(右键单击+拖动)

在图形上单击鼠标右键并拖动以在垂直和水平轴上自由放大和缩小。如果启用了自动缩放图 Graph Autoscale 20.png ,则将根据绘制数据的最大值和最小值来固定垂直轴范围。

Info2.png

其他缩放方式:

  • 按“Shift + F”可缩小到整个画面范围。
  • 通过Alt +右键单击图形并选择要放大的特定帧范围来放大帧范围。
  • 选择帧范围时,按“F”可快速缩放到时间线中的所选范围。

选择帧范围(左键单击+拖动)

在对记录帧的特定范围进行后处理编辑时,使用帧范围选择。通过左键单击并向左和向右拖动鼠标来选择特定范围,所选框架范围将以黄色突出显示。您还可以通过移动选择多个范围来选择多个帧范围。

在导航栏上

导航框架(左键单击)

在导航栏上单击鼠标左键并拖动以擦除记录的帧。您也可以使用鼠标滚动执行相同操作。

平移视图范围

滚动单击并拖动以平移视图范围范围。

帧范围缩放

通过使用导航栏控制柄重新调整范围范围来放大帧范围。您也可以通过Alt +右键单击图形并选择要放大的特定范围来轻松完成此操作。

导航栏

“图表视图”窗格底部的导航栏。

工作范围/播放范围

工作范围(也称为播放范围)既是视图范围,也是相应的拍摄编辑模式的播放范围。仅在工作帧范围内,记录的跟踪数据将被回放并显示在图表上。当从Motive导出跟踪数据时,此范围还可用于输出特定的帧范围。

工作范围可以设置在不同的地方:

  • 在“图形视图”窗格的导航栏中,可以拖动滑块上的手柄以设置工作范围。
  • 您还可以使用“图形视图”窗格上的导航控件放大或缩小帧范围以设置工作范围。
  • 在编辑模式下,也可以从控制台设置工作范围的起始帧和结束帧。

选择范围

选择范围仅用于将后处理编辑应用于Take的特定帧范围。选定的帧范围将在“图形视图”窗格和“时间轴”窗格中以黄色突出显示。

间隙标记

播放录制的捕获时,导航栏上的红色表示标记的遮挡量。较亮的红色表示有更多带标记间隙的标记。

帧范围选择

GraphView SelectedRange 111.png

在图形上单击鼠标左键并拖动以选择特定的帧范围。帧范围选择可用于以下工作流程:

  • 缩放: 通过单击Timeline Recenter.png 按钮或使用F热键快速缩放到所选范围。
  • 跟踪数据导出: 导出所选帧范围的跟踪数据。
  • 重建: 在选定的帧范围上执行后处理重建(重建/重建和自动标记)管道。
  • 标签:仅在选定范围上分配标记标签,修改标记标签或运行自动标签管道。
  • 后处理数据编辑: 仅在选定的帧范围上应用编辑工具。阅读更多:数据编辑
  • 数据删除: 删除所选范围内的3D数据或标记标签。

布局


  • Layout options
  • Context menu

“图形视图”窗格中的布局功能允许用户根据自己的喜好组织和格式化图形。在“图形视图”窗格的右上角的下拉菜单下选择图形布局。

除了从以前版本的Motive迁移的默认图形布局(通道视图,组合视图和轨迹视图)之外,还可以创建自定义布局。使用自定义布局,用户可以指定在每个图形上绘制哪些数据通道,并且每个布局上最多可以配置9个图形。此外,资源选择可以锁定到标记的标记或资源。

系统布局

Info2.png

系统布局”类别下的布局与旧时间轴编辑器中存在的图形相同。

通道视图

通道视图为每个选定的标记提供X / Y / Z曲线,提供详细的运动数据,突出显示数据中的间隙,尖峰或其他类型的噪声。

系统布局:频道视图

组合视图

组合视图为同一绘图中的每个选定标记提供X / Y / Z曲线。此模式对于监视位置更改非常有用,无需转换或重新缩放图形的y轴。

系统布局:通道视图

轨迹视图

轨迹视图是一个简化视图,可以显示间隙,标记交换和其他基本标记问题,可以通过将多个标记轨迹合并在一起来快速解决。您可以从下拉菜单中选择一组特定的标记。选择两个标记时,可以使用文件:Timeline MergeDown 21.png 和合并标签 文件:Timeline MergeUp 21.png

系统布局:轨迹视图

自定义布局

在新的“图形视图”窗格中,可以自定义图形布局以监视捕获中涉及的通道的数据。从ContextMenu dotdotdot.png菜单> 创建新布局选项创建新布局,或右键单击窗格并单击创建新布局选项。

图形布局自定义将在后面的部分中进一步说明:自定义布局

自定义图形布局


一般步骤

在新创建的布局上选择所需的行数和列数

步骤1.创建新布局

通过单击右上角窗格菜单中的“ 创建图形布局”,可以创建新布局 ContextMenu dotdotdot.png

步骤2。设置图表的数量

右键单击图形,转到网格布局,然后选择要放入网格中的行数和列数。(最多9 x 9)

步骤3.打开图表编辑器

“图形视图”窗格中的“数据编辑器
单击 Graph Editor 20.png 工具栏上的图标展开“曲线图编辑器” 。

步骤4.选择图形

单击网格中的图形。该图表将以黄色突出显示。在网格中,使用“曲线图编辑器”进行更改时,只会编辑选定的图形。

步骤5.选择数据通道

接下来,您需要选择要绘制的数据通道。您可以通过在选择图表时选中数据选项卡下的所需通道来执行此操作。仅在所选图表上绘制选中的通道。在这里,您还可以指定在绘制相应数据通道时使用的颜色。

步骤6。格式化视觉效果

然后在“ 可视”选项卡下,格式化图形的样式。您可以配置图形轴,为图形指定名称,显示值等。最重要的是,配置视图样式以匹配所需的图形格式。

Info2.png

在实时模式下绘制实时跟踪数据时,请将“ 视图样式”设置为“ 实时”。可以通过在应用程序设置下更改范围持续时间来调整实时模式图的帧scopr 。

步骤7.重复

重复上述步骤5~6并配置布局中的每个图形。

步骤8.进行选择

选择要监视的资源(标记、刚体、骨架、测力台或NI-DAQ通道)。
锁定符号表示选择已锁定在图表上。

步骤9.锁定选择到图形

锁定选择需要链接到选择的图形。可以从上下文菜单中锁定单个图形(右键单击图形>锁定选择),也可以通过单击文件:GraphView LockSelection 20.png工具栏锁定所有图形。

步骤10.重复锁定选择

锁定所有相关图形后,转到下一个选择并锁定相应的图形。

步骤11.更新布局

如果使用锁定的选择配置了布局,则可以将配置以及隐式选择临时保存到布局中。在将布局细化到显式选择之前,您需要在Motive中选择相关项目以绘制相应的图形。

步骤12.对布局进行细分

最后一步是通过特定布局来明确选择。一旦配置了布局并锁定了所需的选择,您可以通过单击窗格菜单下的“ 详细说明”选项来执行此操作。这会将显式选择固定到布局XML文件上,并且布局将始终查找Take中具有相同名称的特定项。粒子图将GraphView ParticularizedIcon 20.png 在图的右上角显示。
特殊化图。明确地,来自OR6-7-1000板的Fz力数据将绘制在图表上

对布局进行细分

配置完所有图形后,重要的是要定制自定义布局。此操作将保存并明确修复图形锁定的锁定选择。一旦布局有详细说明,您可以在不同的会话上重新打开相同的布局,并绘制来自同一主题的数据通道,而无需再次锁定选择。具体而言,特定布局将尝试查找具有与布局特定的相同名称的项目(标记标记,刚体,骨架,力板或模拟通道)。

图编辑器边栏


可以通过单击Graph Editor 20.png工具栏上的图标来扩展图表编辑器。展开此侧边栏时,您可以选择单个图形,但将禁用其他导航控件。使用图形编辑器,您可以选择图形,选择要绘制的数据通道,并根据需要格式化整体外观。

数据选项卡

GraphView Edit Data 111.png

只有启用或选中的数据通道才会使用指定的颜色绘制在所选图形上。启用通道后,必须选择并锁定资产(标记,刚体,骨架,力板或DAQ通道)。

标记

将选定或锁定标记的3D位置(X / Y / Z)数据绘制到选定图形上。

刚体

将选定或锁定的刚体资产的枢轴点位置(X / Y / Z),旋转(俯仰/偏航/滚动)或平均误差值绘制到所选图形上。

设备

将所选模拟通道的模拟数据从数据采集(NI-DAQ)设备绘制到所选图形上。

力板

绘制所选受力板的力和力矩(X / Y / Z)。绘制的图表尊重力平台的坐标系(z-up)。

Info2.png

使用图表的黑色(0,0,0)将图表颜色设置为3D视口中显示的刚体资产的颜色; 这是在刚体属性下设置的。

可视选项卡

GraphView Edit Visual 111.png

图名

标记所选图表。

查看样式

配置所选图形的样式:
  • 通道:将选定的通道绘制到图形上。
  • 组合:绘制固定在同一图上的每个选定标记的X / Y / Z曲线。
  • 间隙:“轨迹视图”样式允许您轻松监控选定标记上的遮挡间隙。
  • 实时:实时模式用于绘制实时数据。

范围句柄

启用/禁用位于帧选择底部的范围句柄。

行拉伸

设置布局中所选行的高度。高度将由所有拉伸值之和的比率确定: (row stretch value for the selected row)/(sum of row stretch values from all rows) * (size of the pane).

列拉伸

设置布局中所选列的宽度。宽度大小将由所有值之和的比率确定: (column stretch value for the selected column)/(sum of column stretch values from all columns) * (size of the pane).

显示值

显示每个数据集的当前帧值。

显示标签

显示每个绘图数据集的名称。

仅显示主要选择

仅绘制来自主要选择的数据。主要选择是从Motive中选择的最后一项。

显示X网格

显示/隐藏x网格线。

显示Y网格

显示/隐藏y网格线。

主要Y

设置y轴值上主要网格线或刻度线的大小。

次要Y

设置y轴值上的次要网格线或刻度线的大小。

最小Y

设置图表上y轴的最小值。

最大Y

设置图表上y轴的最大值。