来自Wiki
跳转至: 导航搜索
Main PageMotive DocumentationMotive Basics

页面范围

在深入了解具体细节之前,让我们先简要概述一下Motive。如果您不熟悉使用Motive,我们建议您阅读此页面并了解基本工具、配置和导航控件,以及有关管理捕获文件的说明。

文件管理


在Motive中,记录的mocap数据以名为 Take (TAK)的文件格式存储,并且多个Take文件可以在会话文件夹中分组。 数据窗格是在Motive中管理捕获文件的主要界面。可以从Toolbar Data Icon.png工具栏上的图标访问此窗格,它包含会话文件夹列表以及在Motive中记录或加载的相应Take文件。

Motive将保存和加载Motive特定的文件格式,包括Take文件(TAK)、相机校准文件(CAL)和Motive用户配置文件(MOTIVE),其中包含大多数软件设置以及骨架和刚体的资源定义对象。资源定义与Motive中的可跟踪对象相关,将在 刚体跟踪骨架跟踪 页面中进一步说明。


  • Motive Data pane
  • Windows File Explorer

Take文件 (.TAK)

MotiveBasics TAK.png

Motive文件管理以Take(TAK)文件为中心。TAK文件是单个动作捕捉记录(也称为“拍摄”或“试用”),其中包含从文件重建整个捕获所需的所有信息,包括相机校准、相机2D数据、重建和标记的3D数据、数据编辑、解决关节角度数据,跟踪模型(Skeletons,RigidBodies)和任何其他设备数据(音频、测力台等)。Motive Take(TAK)文件是一个完全独立的动作捕捉录音,可以在另一个系统上由另一个版本的Motive打开。

会话文件夹

会话是一个文件夹,允许用户组织多个类似的拍摄(例如周一、周二、周三或StaticTrials、WalkingTrials、RunningTrials等)。无论您是计划当天拍摄还是整合一组Takes中期项目,创建会话文件夹都可以帮助管理复杂的数据集。在 数据窗格中, 您可以导入包含多个Takes的会话文件夹,也可以创建新文件夹以启动新的捕获会话。要获得最有效的工作流程,请在捕获之前规划动作捕捉会话,并组织需要完成的捕获(镜头)列表。输入Take 电子表格或文本文件中的名称,以及复制并粘贴列表,这将自动创建带有粘贴列表中相应名称的空Takes(镜头列表)。

Motive用户档案 (.MOTIVE)

MotiveBasics MOTIVE.png

软件配置保存在Motive配置文件(* .motive)文件中。在Motive配置文件中,保存并保留所有与应用程序相关的配置、资源列表和加载的会话文件夹。您可以导出和导入配置文件,以便在每次启动Motive时轻松维护相同的软件配置。

所有当前配置的软件设置将在 C:\ProgramData\OptiTrack\MotiveProfile.motive 整个捕获期间以及关闭Motive时定期保存到文件中。此文件是默认的应用程序配置文件,并在再次启动Motive时将其加载回来。也可以通过帮助→应用程序文件夹→持久设置访问包含文件夹。这允许所有配置保持在Motive的不同会话之间。如果要将所有设置恢复为出厂默认设置,请使用主命令栏的“ 编辑”选项卡下的“ 重置应用程序设置”按钮。

还可以从主命令栏的“ 文件”菜单中导出和导入Motive配置文件。使用配置文件,您可以轻松地在不同实例和不同计算机之间传输和保留Motive配置。

以下内容保存在应用程序配置文件中:

  • 应用程序设置。包括重建设置
  • 流媒体设置
  • 同步设置
  • 导出设置
  • 刚体和骨架资源。
  • 刚体和骨架设置。
  • 标签设置
  • 热键配置

Info2.png

Project TTP文件怎么了?:从2.0版本开始,不推荐使用TTP项目文件格式。现在,只需将会话文件夹直接加载到新的“数据管理”窗格即可管理录制的Takes。对于导出和导入软件设置配置,Motive配置文件格式将替换TTP文件的先前角色。在Motive配置文件中,将包含软件配置,例如重建设置、应用程序设置、数据流设置和许多其他设置。相机校准将不再保存在TTP文件中,但它们仅保存在校准文件(CAL)中。 TTP文件仍然可以在Motive 2.0中加载。但是,我们建议不要使用TTP文件。

校准文件 (CAL)

MotiveBasics CAL.png

校准文件是一个独立文件,包含完全恢复校准摄像机音量所需的所有信息; 包括每个相机的位置和方向,镜头失真参数和相机设置。校准摄像机系统后,可以在需要时将CAL文件导出并重新导入Motive。因此,建议在每轮校准后保存相机校准文件。

请注意,重建设置也会存储在校准文件中; 就像它如何存储在MOTIVE配置文件中一样。如果在加载配置文件后导入校准文件,它可能会在导入时覆盖以前的重建设置。

请注意,只有在校准后摄像机设置保持不变时,此文件才可靠。从校准 页面了解更多信息。

Info2.png

默认系统校准

默认系统校准将保存到C:\ProgramData\OptiTrack\Motive\System Calibration.cal 文件中,并在应用程序启动时自动加载,以提供对3D卷的即时访问。每次修改校准或关闭Motive时,此文件也会更新。

视窗


在Motive中,主视窗固定在UI的中心,用于在实时和编辑模式下监视2D或3D捕获数据。透视视图模式 Viewport18.png 显示了校准的3D空间内的重建的3D数据,并且将相机预览模式Viewport1.png 显示2D图像从设定每个摄像机。这两种观点对于评估和监控跟踪数据至关重要。

教程视频:Motive中的2D和3D视图

透视图 - 3D视窗

  • 用于查看捕获的重建3D表示、分析标记位置、重建中使用的光线等。
  • 透视视图中的上下文菜单允许您访问与3D跟踪数据中的标记和资源相关的更多选项。
3D perspective view pane in Motive

相机预览 - 2D视窗

  • 可以从 摄像头预览窗格访问每个摄像头的视图。它显示从每个摄像头传输的图像。显示图像处理模式,包括灰度和对象
  • 此窗格中还显示检测到的反射,以及满足对象过滤并被视为标记的反射
  • 在“相机预览”窗格中,您可以 屏蔽 某些像素区域以将其从过程中排除。
2D Camera Preview

基本导航控件


Info2.png

Motive中的大多数导航控件都是可自定义的,包括鼠标和 热键 控件. “编辑”选项卡下的“热键编辑器窗格”和“鼠标控制窗格”允许您自定义鼠标导航和常用操作的键盘快捷键。

查看端口鼠标控件

鼠标控制窗格用于自定义导航鼠标控件。

Motive包括各种常见的鼠标控制预设'配置文件',以便任何新用户都可以轻松地开始控制Motive。可用的预设控制配置文件包括Motive、Blade、Maya和Visual3D。您还可以打开“编辑”选项卡下的“鼠标控制”窗格,并根据自己的喜好自定义设置。


功能 默认控制
旋转视图 右+拖
平移视图 中间(滚轮)单击+拖动
放大/缩小 鼠标滚轮
在视图中选择 鼠标左键单击
在视图中切换选择 CTRL +鼠标左键单击

热键

使用热键可以加快工作流程。所有默认热键都列在Motive Hotkeys页面中。也可以从热键编辑器(如下所示)自定义热键,可以在主工具栏的“ 编辑”选项卡下访问。可以使用热键编辑器使用自定义热键分配各种操作。 有关默认热键设置的列表,请通读 Motive 热键页面.

Basics Hotkey 20.png

控制台


控制台总是放在Motive的底部,并可以通过Motive的两种主要操作模式提供了记录和导航控件:实时模式和编辑模式。

现场模式

Control Deck in Live Mode.

编辑模式

Control Deck in Edit Mode.

实时模式和编辑模式

实时模式中, 所有摄像机都处于活动状态,系统正在处理摄像机数据。如果动作捕捉系统已校准,Motive是实时重建的2D相机数据转换成在标记和未标记的3D轨迹(标记) 实时。可以使用 数据流 工具或NatNet SDK 将实时跟踪数据流式传输到其他应用程序。此外,在实时模式下,该系统已准备好记录和相应的捕获控制将在控制台

编辑模式中, 相机是不活动的,并且Motive被处理加载Take文件(预先记录的数据)。控制台中将提供播放控件,控制台顶部将显示小时间线,用于擦除录制的帧。在此模式下,您可以在 导出跟踪数据之前,从TAK查看记录的3D数据并进行后处理编辑 /手动将标记 标签 分配给记录的轨迹。此外,需要时,您可以切换到 2D 模式, 并查看实时重建的3D数据以了解如何获得3D数据并执行后处理重建流水线以重新获得一组新的3D数据。


  • 现场模式。
  • 编辑模式


图表视图窗格


图表视图窗格 用于在Motive中绘制实时或录制的频道数据。例如,可以在该窗格上绘制重建标记的3D坐标、刚体资产的3D位置和取向、测力台数据、来自数据采集设备的模拟数据等。您可以在现有布局之间切换,也可以创建自定义布局以绘制特定通道数据。

基本导航控件如下所示。有关更多信息,请阅读 图表视图窗格 页面。

Graph View in Motive

基本导航控件


在图上

导航帧(Alt +左​​键单击+拖动)

按住Alt +左​​键单击图形并左右拖动鼠标以浏览记录的帧。您也可以使用鼠标滚动执行相同操作。

平移(滚动点击+拖动)

滚动单击并拖动以在整个绘制的图形中垂直和水平平移视图。向左和向右拖动光标将沿着水平轴平移视图以用于所有图形。垂直导航时,滚动单击图形并向上和向下拖动以垂直平移特定图形。

缩放(右键单击+拖动)

在图形上单击鼠标右键并拖动以在垂直和水平轴上自由放大和缩小。如果启用了自动缩放图Graph Autoscale 20.png,则将根据绘制数据的最大值和最小值来固定垂直轴范围。

Info2.png

其他缩放方式:

  • 按“Shift + F”可缩小到整个画面范围。
  • 通过Alt +右键单击图形并选择要放大的特定帧范围来放大帧范围。
  • 选择帧范围时,按“F”可快速缩放到时间线中的所选范围。

选择帧范围(左键单击+拖动)

在对记录帧的特定范围进行后处理编辑时,使用帧范围选择。通过左键单击并向左和向右拖动鼠标来选择特定范围,所选框架范围将以黄色突出显示。您还可以通过移动选择多个范围来选择多个帧范围。

在导航栏上

导航框架(左键单击)

在导航栏上单击鼠标左键并拖动以擦除记录的帧。您也可以使用鼠标滚动执行相同操作。

平移视图范围

滚动单击并拖动以平移视图范围范围。

帧范围缩放

通过使用导航栏控制柄重新调整范围范围来放大帧范围。您也可以通过Alt +右键单击图形并选择要放大的特定范围来轻松完成此操作。

导航栏

“图表视图”窗格底部的导航栏。

工作范围 / 播放范围

工作范围(也称为播放范围)既是视图范围,也是相应的拍摄编辑模式的播放范围。仅在工作帧范围内,记录的跟踪数据将被回放并显示在图表上。当从Motive导出跟踪数据时,此范围还可用于输出特定的帧范围。

工作范围可以设置在不同的地方:

  • 在“图形视图”窗格的导航栏中,可以拖动滑块上的手柄以设置工作范围。
  • 您还可以使用“图形视图”窗格上的导航控件放大或缩小帧范围以设置工作范围。
  • 在编辑模式下,也可以从Control Deck 设置工作范围的起始帧和结束帧。

选择范围

选择范围仅用于将后处理编辑应用于Take的特定帧范围。选定的帧范围将在“图形视图”窗格和“时间轴”窗格中以黄色突出显示。

差距指示

播放录制的捕获时,导航栏上的红色表示标记标记的遮挡量。较亮的红色表示有更多带标记间隙的标记。

应用程序设置


可以在“ 编辑”选项卡下或单击主工具栏上的图标访问 Application SettingsToolbar AppSettings 20.png

此窗格用于配置应用程序范围的设置,包括启动配置,2D和3D视口的显示选项,资产创建设置,最重要的是,实时重建的参数和摄像机的2D过滤器设置。“ 摄像机”选项卡包括2D滤镜设置,这些设置基本上确定哪些反射被视为摄像机视图上的标记反射,并且实时重建参数确定从所有摄像机的一组标记反射在场景中重建哪些3D标记。 Application Settings 页面中记录了可用设置的参考。

Info2.png

如果要重置默认应用程序设置,请转到“编辑”选项卡下的“重置应用程序设置”。

实时重建设置

Reconstruction tab下, 您可以配置实时Point-Cloud Reconstruction引擎。重建设置是Motive中最重要的设置之一。这些设置确定如何从捕获的2D相机图像中获取3D坐标。因此,了解这些设置对于优化系统以获得最佳跟踪结果非常重要。

相机设置

Camera tab下, 您可以配置2D摄像机滤镜设置(圆形滤镜和尺寸滤镜)以及摄像机的其他显示选项。2D相机滤镜设置是优化捕捉的关键设置之一。对于大多数应用程序,默认设置运行良好,但了解一些核心设置仍然有益,以便更有效地控制相机系统。

有关更多信息,请阅读 应用程序设置 页面以及 重建和2D模式

布局


Motive中的UI布局是可自定义的。所有窗格都可以从UI停靠和取消停靠。可以使用屏幕上的对接指示器通过拖放来定位和组织每个窗格。窗格可以浮动、停靠或堆叠。当堆叠在一起时,它们形成一个标签窗口,以便快速循环。可以保存和加载Motive中的布局,允许用户在适合不同需求的默认配置和自定义配置之间快速切换。Motive具有用于校准,创建骨架,捕获(记录)和编辑工作流程的预设布局。可以从主菜单 - >'布局'菜单项创建,保存和设置自定义布局作为默认布局。从“布局”菜单,“主菜单”右上角的“布局下拉列表”或HotKeys快速恢复特定布局。

Info2.png

注意:无法在Motive 2.0中加载旧版本的布局配置。请重新创建和更新布局以供使用。

  • Docking indicator
  • Motive layout options
  • 布局特征概述。



模板:BackNext