来自Wiki
跳转至: 导航搜索

Quick Start Guide: Getting Started


Main PageQuick Start GuidesGetting Started

欢迎使用Quick Start Guide: Getting Started!

本指南简要介绍了如何安装和使用OptiTrack动作捕捉系统。本页的每个部分都总结了关键概念和说明,以帮助您熟悉系统并开始您的捕获体验。

请注意,Motive提供的功能远远超出本指南中列出的功能,系统的功能可以进一步优化,以适应您使用附加功能的特定捕获应用程序。有关每个工作流程的更多详细信息,请通读此Wiki中的相应工作流程页面:硬件设置软件设置

GettingStarted Intro.png

硬件设置


准备捕获区域

Example capture area

为获得最佳跟踪结果,您需要在设置系统之前准备并清理捕获环境。删除可能阻挡相机视图的不必要障碍物。在室内拍摄时,遮盖开窗并尽量减少入射的阳光。避免在反光地板上安装系统,因为相机的LED照明会反射出来。如果不能选择,请使用橡胶垫覆盖反射区域。具有反射表面或照明特征的物品应移除或用非反射材料覆盖,以避免外来反射。

良好捕获区域的关键检查点

  • 最大限度地减少环境光,尤其是阳光和其他红外光源。
  • 清洁捕获量。删除该区域内不必要的障碍物。
  • 磁带或盖子,区域内剩余的反射物体。

另请参阅: 硬件设置工作流程页面。

模板:PrintPageBreak

布线和负载均衡

以太网相机系统

以太网相机型号:Prime系列和Slim 13E相机。按照以下接线图连接每个所需的系统组件。


单PoE交换机设置

Ethernet system components setup.
  • 将PoE交换机连接到主机PC: 首先通过以太网电缆将PoE交换机连接到主机PC。由于摄像机系统占用大量数据带宽,因此以太网摄像机网络流量必须与办公室/局域网分离。如果用于捕获的计算机连接到现有网络,则需要使用第二个以太网端口或附加网卡将计算机连接到摄像机网络。执行此操作时,请确保在Windows防火墙设置下关闭特定网络的计算机防火墙。
  • 将以太网摄像机连接到PoE交换机:以太网摄像机使用Cat 6或更高版本的以太网电缆通过PoE / PoE +交换机连接到主机PC。
  • 为交换机供电: 每台摄像机均由PoE交换机供电。PoE和PoE +交换机必须同时支持每个端口的全功率(分别为15.4和34.2瓦)。
  • 以太网电缆: 以太网电缆连接受PoE(以太网供电)和以太网通信标准的限制,这意味着使用Cat 6电缆(以太网电缆类型Cat5e或以下电缆不支持)时,摄像机和交换机之间的距离可达约100米。为获得最佳性能,请勿将捕获计算机以外的设备连接到摄像机网络。如果需要其他以太网端口,则应安装附加网卡。
  • 外部同步: 如果要连接外部设备,请使用eSync同步中心。使用以太网电缆将eSync连接到其中一个PoE交换机。

多个PoE开关设置可实现更高的相机计数

Ethernet system components setup for high camera counts.
  • 上行链路交换机: 对于使用多个PoE交换机的摄像机数量较多的系统,请使用上行链路以太网交换机将所有交换机链接并连接到主机PC。最后,交换机必须以星型拓扑连接,中心节点的上行链路交换机连接到主机PC。切勿将多个PoE交换机串联菊花链,因为这样做会给系统带来延迟。


  • 高摄像头计数: 为了设置超过24个Prime系列摄像头,我们建议使用10千兆位上行链路交换机,并通过支持10千兆位传输速率的以太网电缆将其连接到主机PC - Cat6a,Cat6e和Cat7。这将提供更大的数据带宽并减少数据传输延迟。
另请参阅: 接线和布线页面。

USB摄像头系统

USB相机型号:Flex系列和Slim 3U相机型号。按照以下接线图连接每个所需的系统组件。

USb系统接线图。
  • USB电缆:请记住USB电缆长度限制,每条USB 2.0电缆的长度不得超过5米。
  • 将OptiHub连接到主机PC:使用USB 2.0电缆(A / B型)将每个OptiHub连接到主机PC。要优化可用带宽,请在主机PC的不同USB适配器之间均匀分配OptiHub连接。对于大型系统设置,最多可使用两个5米有源USB扩展连接OptiHub,总长度为15米。
  • 为Optihub供电:使用提供的电源适配器将每个OptiHub连接到外部电源。所有USB摄像头都将由OptiHub供电。
  • 将摄像机连接到OptiHub:使用USB 2.0电缆(B / mini-b型)将每个USB摄像机连接到OptiHub。使用多个OptiHub时,请在OptiHub之间均匀分配相机连接,以平衡处理负荷。请注意,将相机连接到OptiHub时不支持USB扩展。
  • 多个OptiHub:一个系统可以使用多达四个OptiHub,24个USB摄像头。设置多个OptiHub时,必须使用RCA同步电缆在串联链中连接或级联所有OptiHub。更具体地说,一个OptiHub 的Hub SYNC输出端口需要连接到另一个OptiHub 的Hub Sync输入端口,如图所示。
  • 外部同步:集成外部设备时,请使用每个OptiHub上提供的外部同步输入/输出端口。
另请参阅:瞄准和聚焦页面。

跟踪条

跟踪栏设置。

Duo / Trio跟踪条使用I / OX USB集线器为设备供电(3.0 A),连接到计算机(USB A-B),并与外部设备同步。

放置和瞄准相机

光学运动捕捉系统利用来自每个相机的多个2D图像来计算或重建相应的3D坐标。为了获得最佳跟踪结果,必须放置摄像机,使每个摄像机捕获目标捕获区域的独特优势。将摄像机环绕捕捉体积环绕,如下例所示,以便至少两个摄像机始终可以看到体积中的标记。 Mount 将摄像机安全地安装到稳定的结构(例如桁架系统)上,以便它们在整个捕获过程中不会移动。 使用三脚架或摄像机支架时,请确保将它们放置在稳定的位置。放置好相机后,瞄准相机,使它们的视野在大部分拍摄发生的区域重叠最多。 校准后的任何相机移动都需要重新校准系统。应在相机电缆的相机端使用电缆张力消除装置,以防止对相机造成潜在损坏。

另请参阅:相机放置相机支架结构页面
  • 使用相机夹具支撑相机
  • 样例放置。
  • 瞄准每个相机,使其视图在目标体积上重叠。

镜头焦点

为了获得准确和稳定的跟踪数据,所有摄像机正确聚焦到目标体积非常重要。这对于近距离拍摄和远距离拍摄尤为重要。对于常见的跟踪应用程序,焦点到无穷大应该可以正常工作,但是,确认系统中的每个摄像头都是聚焦的仍然很重要。

要调整或检查相机焦距,请在目标跟踪区域放置一些标记。然后,将相机设置为原始灰度模式,增加曝光和LED设置,然后放大到捕获体积中的一个逆向反射标记并检查图像的清晰度。如果图像模糊,请调整相机焦距并找到最佳分辨标记的位置。

另请参阅: 瞄准和聚焦页面
  • 失焦
  • 适度聚焦
  • 聚焦

软件设置


主机PC要求

为了使用Motive正确运行动作捕捉系统,主机PC必须满足最低系统要求。所需的最低规格取决于mocap系统的大小和所用摄像机的类型。请咨询我们的Sale Engineers,或使用我们网站上的Build Your Own feature 功能查找主机PC规格要求。

Motive安装

Motive splash screen: License activation.

Motive是一个软件平台,旨在控制各种跟踪应用的动作捕捉系统。Motive不仅允许用户校准和配置系统,而且还提供用于捕获和处理3D数据的接口。捕获的数据可以记录或实时流式传输到其他管道中。

如果您是Motive的新手,我们建议您在阅读本指南后阅读Motive Basics页面,了解Motive中的基本导航控件。

下载并安装

要安装Motive,只需从Motive Download Page下载适用于您的操作系统的Motive软件安装程序,然后运行安装程序并按照其提示进行操作。

Info2.png

注意:杀毒软件可能会干扰Motive与摄像头或其他设备通信的能力,可能需要禁用或配置杀毒软件才能让设备通信正常运行。

许可证激活步骤

  1. 将硬件许可证密钥插入计算机。
  2. 启动Motive
  3. 使用许可工具激活您的软件,可在Motive初始屏幕中访问该工具。您需要输入许可证的许可证序列号和哈希码。
  4. 激活后,许可证工具会将与硬件密钥关联的许可证文件放在许可证文件夹中。有关更多许可证激活问题,请访问 Licensing FAQs或联系我们的技术支持

首次启动

首次启动Motive时,将显示“快速启动”面板,您可以使用此面板快速开始执行特定任务。默认情况下,Motive将从校准布局开始。使用此布局,您可以校准相机系统并构建3D跟踪音量。请注意,对于不同的相机型号或软件许可证,初始布局可能略有不同。

下表简要说明了初始布局中某些面板的用途:

Motive at its first glance.


UI名称 描述 相关页面
快速入门面板 快速启动面板可在使用Motive时快速访问典型的初始操作。每个选项都会快速引导您进行相应选择的布局和操作。如果您不想再次看到此面板,可以取消选中底部的框。可以在Help选项卡下重新访问此面板。
  • N/A
设备窗格 已连接的摄像机将列在设备窗格。您可以在此面板中为每个摄像机配置设置(FPS、曝光、LED等),并决定是使用所选摄像机进行3D跟踪文件:Camera TrackingMode.png还是参考文件:Camera ReferenceMode 21.png视频。只有设置为跟踪模式的摄像机才有助于重建3D坐标。 参考模式下的相机捕获灰度图像仅供参考。可以在Motive中的“视图”选项卡下或单击文件:Tb10.png主工具栏上的图标访问“设备”窗格。

设备窗格

属性窗格 在Motive中选择项目时,其所有相关属性将列在属性窗格。例如,如果您在3D视口中选择了骨架,则其相应的属性将列在此窗格下,您可以查看设置并根据需要进行配置。您也可以选择连接的摄像机、同步装置、刚体,在列出的任何外部设备的设备窗格,或记录注意到查看和配置它们的属性。此窗格将用于几乎所有工作流程。可以在Motive中的“视图”选项卡下或单击Toolbar Properties Icon.png主工具栏上的图标访问设备窗格。

属性窗格

透视视图窗格 透视图窗格 是Motive中显示3D数据的位置。在这里,您可以在校准的捕获体积内查看、分析和选择重建的3D坐标。该面板可用于实时捕捉和录制数据回放。您还可以选择多个标记并定义刚体和骨架资源。如果需要,可以在视图选项卡或单击工具栏视图Toolbar Views 20.png主工具栏上的图标打开其他视图窗格。

透视图窗格

相机预览窗格 “摄像头预览”窗格显示系统中摄像头的2D视图。在这里,您可以监控每个摄像机视图并应用掩模过滤器。此窗格还用于检查捕获或过滤的2D对象(圆形反射),以便检查处理和重建为3D坐标的反射。如果需要,可以在视图选项卡或单击工具栏视图Toolbar Views 20.png主工具栏上的图标打开其他视图窗格。

相机预览窗格

校准窗格 校准窗格用于摄像机校准过程。为了从捕获的2D图像计算3D坐标,需要首先校准相机系统。校准所需的所有工具都包含在校准窗格中,也可以在视图选项卡或单击Toolbar Calib 20.png主工具栏上的图标进行访问。

校准窗格 校准

控制甲板 控制台位于Motive的底部,您可以在其中控制捕获数据的录制(实时模式)或播放(编辑模式)。在实时模式下,您可以使用控制台开始录制并为捕获分配文件名。在编辑模式下,你可以使用此窗格来控制的条记录回放Take(s)

控制台


Info2.png

另请参阅:文档参考指南页面中的UI页面列表。

视口导航控件

使用以下控件在Motive中的2D和3D视口中导航。大多数导航控件都是可自定义的,包括鼠标和热键编辑选项卡下的热键编辑器窗格鼠标控制窗格允许您自定义鼠标导航和常用操作的键盘快捷键。

功能 默认控制
旋转视图 右+拖
潘视图 中间(滚轮)单击+拖动
放大/缩小 鼠标滚轮
在视图中选择 鼠标左键单击
在视图中切换选择 CTRL +鼠标左键单击

相机设置

现在摄像机已连接并显示在Motive中,下一步是配置摄像机设置。适当的相机设置将根据各种因素而变化,包括捕获环境和跟踪对象。总体目标是配置设置,以便在每个摄像机的2D视图中清晰地捕获和区分标记反射。有关各个设置的详细说明,请参阅设备窗格页面。

要检查相机设置是否已优化,最好同时检查灰度模式图像和跟踪模式(对象或精度)图像,并确保标记反射从图像中突出。您可以在Motive中将相机切换到灰度模式,也可以使用辅助瞄准按钮将相机切换为支持的相机。在Motive中,您可以右键单击相机预览窗格并在上下文菜单中切换视频模式,也可以通过属性窗格更改视频模式。

曝光设置

曝光设置决定了每帧数据对相机成像器曝光的时间。曝光时间越长,相机将捕获更多光线,从而创建更亮的图像,从而提高小型和暗淡标记的可视性。但是,高曝光值会导致错误标记,较大的标记绽放和标记模糊 - 所有这些都会对标记数据质量产生负面影响。只要标记在捕获的图像中清晰可见,最好最小化曝光设置。

  • 使用 设备窗格调整摄像机设置。 这也可以通过 属性窗格
  • 在灰度图像上显示的逆向反射标记。

捕获设置


相机校准

Info2.png

提示: 对于校准过程,单击布局→校准菜单(CTRL + 1)以访问校准布局。

为了开始跟踪,必须首先校准所有摄像机。通过相机校准过程,Motive计算相机的位置和方向(外在)以及捕获图像(内在因素)中镜头失真的数量。使用校准结果,Motive构建3D捕获体积,并在该体积内完成运动跟踪。所有校准工具都可以在校准窗格下找到。阅读校准页面,了解校准过程以及可用于提高工作效率的其他工具。

另请参见: 校准 页面。

校准步骤

扫读一个捕获体使用cw - 500校准魔杖。

掩蔽

  1. 移除任何不需要的物体,并物理覆盖捕获体积内任何外来的红外光反射或干扰。
  2. [Motive:Calibration pane] 在Motive中,打开校准窗格或使用校准布局(CTRL + 1)。
  3. [Motive:Calibration pane] 单击相机预览窗格中的View2D ClearMask 1.11.png按钮。
  4. [Motive:Calibration pane] 使用Motive屏蔽剩余的无关反射。单击校准窗格中的可视化模块 ,或使用 相机预览窗格中的View2D AutoMask 1.11.png图标,应用软件蒙版以自动阻止无法从卷中移除的任何光源或反射。应用遮罩后,“2D相机预览”窗格中的所有无关反射(白色)将覆盖红色像素。

读磁

  1. 带出校准棒。
  2. [Motive:Calibration pane] 从校准窗格中,确保Calibration Type设置为Full,并在OptiWand部分下指定正确的棒类型。
  3. [Motive:Calibration pane] 单击Start Wanding开始扫读。
  4. 将魔杖放入捕获体积,并在整个体积中挥动魔杖,并允许摄像机收集鲸鱼样本。
  5. [Motive:Calibration pane] 当系统显示已收集到足够的样本时,单击“ 计算”按钮开始计算。这可能需要几分钟。
  6. [Motive:Calibration pane] 启用Ready to Apply按钮后,单击Apply Result
  7. [Motive] 将显示校准结果窗口。检查完wanding结果后,单击Apply'以应用校准。
CS-400校准方块。

设置地平面

  1. 既然已经校准了所有摄像机,则需要定义捕获体积的地平面。
  2. 在校准体积内放置校准方块。定位正方形,使顶点标记直接放在所需的全局原点上。
  3. 调整校准方块的方向,使较长的臂指向所需的+ Z轴,较短的臂指向体积的所需+ X轴。Motive使用y-up右手坐标系。
  4. 将校准方块平行于地平面调平。
  5. (可选)在Motive 的3D视图中,选择校准方形标记。如果校准方块上的反光标记是捕获体积内唯一的重建,Motive将自动检测标记。
  6. 访问校准窗格中的“地平面”选项卡。
  7. 选择校准方形标记时,单击“地平面校准方块”部分中的“ 设置地平面 ”。
  8. Motive将提示您保存校准文件。将文件保存到相应的会话文件夹。


模板:TrackingBar


在Motive中贴标签。在标签页面中了解最新的标签工作流程。

设置捕获会话

捕获录音

在Motive 2.0中,每个捕获都将保存在Take (TAK)文件中,相关的Take文件将分组到session folders中。首先创建一个新的Session文件夹,开始捕获。在主计算机的所需目录中创建一个新文件夹,然后通过单击图标或将它们拖放到数据管理窗格中,将该文件夹加载IconAddSession.png数据管理窗格中。如果没有加载会话文件夹,它将在用户文档目录上自动创建会话文件夹(例如,Session 2017-04-26)。所有新录制的Takes都将保存在当前选定的会话文件夹中,该文件夹将用DataManagementPane Flag 111.png符号标记。

另请参阅: Motive基础页面。

  • “数据管理”窗格中加载的会话文件夹。
  • Windows文件资源管理器中的示例会话文件夹。

Motive配置文件

Motive的软件配置保存到Motive Profiles(* .motive扩展名)。所有与应用程序相关的设置都可以保存到Motive配置文件中,您可以导出和导入这些文件,并轻松维护相同的软件配置。

标记起来

将反光标记放置在您想要跟踪的主体(刚体或骨架)上。仔细检查标记是否牢固连接。对于骨架跟踪,请打开构建器窗格,转到骨架创建选项,然后选择要使用的标记集。按照骨架头像图放置标记。如果您使用的是mocap套装,请确保套装尽可能紧密贴合。Motive从您放置在套装上的相关标记中获取每个身体部分的位置。因此,重要的是尽可能地防止标记的移位。样品标记放置如下所示。

另请参阅: 标记类型的标记页面,或放置方向的刚体跟踪骨架跟踪页面。

  • 逆向反射标记放在直升机上
  • 相应的刚体在Motive中定义
  • 标记放置一个主题。
  • 构建器窗格中显示的基线(41)骨架显示的标记放置。

定义骷髅和刚体

Info2.png

提示: 要创建可跟踪资源,请单击布局→创建菜单项以访问模型创建布局。

创建刚体

要定义刚体,只需在“透视视图”中选择三个或更多标记,单击鼠标右键,然后选择“ 刚体”→“从所选内容创建刚体 ”。您还可以使用CTRL + T热键来创建刚体资产。您还可以使用构建器窗格来定义刚体。

Creating a rigid body using  the构建器窗格.

创建骨架

要定义骨架,请让作用对象在适当的位置输入标记并附加标记。打开构建器窗格,然后选择Skeleton和Create。在标记设置部分下,选择您要使用的标记集,并显示具有所需标记位置的相应模型。在验证作用对象上的标记位置与构建器窗格中的标记位置相对应后,指示actor调整校准姿势。最常用的校准姿势是T形姿势。T型姿势需要适当的站立姿势,背部挺直,头部直视前方。然后,两臂伸展到两侧,形成“T”形。在T-pose中,在3D视图中选择所需骨架内的所有标记,然后单击构建器窗格中的“创建”按钮。在某些情况下,如果只有所需的作用对象在视图中,您可能不需要选择标记。

另请参阅: 刚体跟踪页面和骨架跟踪页面。

  • 在Motive中创建骨架资源。 请注意,本教程视频是在较早版本的Motive中捕获的。在2.1中,构建器窗格将用于创建,但一般工作流程仍然相同
  • 使用构建器窗格定义骨架

记录数据

Info2.png

提示: 要记录捕获,请访问布局→捕获菜单项,或访问捕获布局

一旦校准了体积并定义了骨架,现在就可以捕获了。在底部的控制台,按下灰色的红色记录按钮,或者在录像模式 按空格键即可开始捕捉。此按钮将以亮红色亮起,表示正在进行录制。您可以再次单击录制按钮停止录制,相应的捕获文件(TAK扩展名)(也称为捕获Take)将保存在当前会话文件夹中。一旦采取已被保存,你可以播放捕获、重建、编辑,并以多种格式导出数据进行进一步的分析或与大多数3D软件使用。

跟踪骨架时,以T姿势开始和结束捕获是有益的。这允许您在需要时在后处理中重新创建骨架

另请参阅: 数据记录页面。

捕获后


数据编辑

捕获一个Take后。可以使用数据编辑工具对记录的3D数据及其轨迹进行后处理,该工具可在编辑工具窗格中找到。数据编辑工具提供后处理功能,例如删除不可靠的轨迹,平滑选择轨迹以及插入缺失(遮挡)标记位置。对3D数据进行后期编辑可以提高跟踪数据的质量。

Info2.png

提示: 对于数据编辑,请访问布局→编辑菜单项,或访问捕获布局

一般编辑步骤

  1. 浏览Take中的整体框架,了解需要清理哪些框架和标记。
  2. 请参阅标签窗格并检查每个标记中的间隙百分比。
  3. 选择经常被遮挡或放错地方的标记。
  4. 查看图形视图窗格中的框架,并检查轨迹中的间隙。
  5. 对于帧中的每个间隙,在解决的标记位置附近的预期位置处寻找未标记的标记。如果存在未标记的标记,则重新分配正确的标记标记
  6. 使用裁剪Tails功能裁剪每个间隙中轨迹的两端。它可以裁剪与可能存在跟踪错误的间隙相邻的几帧。这为空隙填充准备了遮挡的轨迹。
  7. 找到要填充的间隙,并使用填充间隙功能对遮挡标记的估计轨迹进行建模。

标记

Unlabeled markers displayed in orange.
Labeled markers displayed in white.

在Motive中,捕获的标记被重建为3D坐标。需要为Motive标记重建的标记以区分捕获内的不同重建。注释重建的轨迹可以单独导出或使用(完全解决)以跟踪目标对象的移动。与刚体和骷髅相关的标记通过自动标记过程自动标记。请注意,在实时模式(捕获前)和编辑模式(捕获后)期间,可以自动标记刚体和骨架标记。也可以标记单个标记,但是需要使用标记设置资源标签窗格在后处理中手动标记每个标记。这些手动标签工具也可用于纠正任何标签错误。阅读标签页面,了解有关分配和编辑标记标签的更多详细信息。

  • 自动标注: 使用相应的资产定义自动标记刚体标记和骨架标记的集合。
  • 手动标签: 使用标签窗格手动标记单个标记,指定标记集,刚体或骨架资源中定义的标记。

另请参阅: 标签页面。

在Motive中贴标签。在标签页面中了解最新的标签工作流程。

数据导出


  • 跟踪数据导出对话框的动机。CSV导出选择和相应的导出选项列出。

Motive以各种文件格式导出重建的3D跟踪数据,导出的文件可以导入其他管道以进一步利用捕获数据。支持的格式包括Motive: Tracker的 CSV和C3D ,以及Motive: Body的 FBX,BVH和TRC 。要导出的跟踪数据,选择采取出口并打开导出对话框窗口,可以从访问文件→导出跟踪数据或在采取→导出跟踪数据右击从数据管理窗格。可以从Motive或使用Motive批量处理选择和导出Multiple Takes。在导出对话框窗口中,可以配置导出数据的帧速率,测量比例和帧范围。在导出文件之前,还可以通过在视图窗格中选择帧范围来指定帧范围。在导出对话框窗口中,每种文件格式都有相应的导出选项。

另请参阅: 数据导出页面。

数据流


数据流在动机允许您捕获数据流到其他应用程序中。

Motive提供多种选项,可以实时将跟踪数据流式传输到外部应用程序。跟踪数据可以在实时模式和编辑模式下流式传输。流媒体插件可用于Autodesk Motion Builder,Visual3D,The MotionMonitor,虚幻引擎4,3ds Max,Maya(VCS),VRPN和trackd,它们可以从OptiTrack网站下载。对于其他流媒体选项,NatNet SDK使用户能够构建自定义客户端和服务器应用程序以流式传输捕获数据。常见的动作捕捉应用程序依赖于实时跟踪,而OptiTrack系统旨在以极低的延迟提供数据,即使在流式传输到第三方管道时也是如此。有关特定 流量协议的详细说明包含在相应插件或SDK附带的PDF文档中。

另请参阅: 数据流页面和 数据流窗格页面。